Back to Forum
Page 1 of 2 12 LastLast
Results 1 to 20 of 22
  1. sampletext is offline
    This user has no status.
     
    Established TTD Member 45 197
    S
    sampletext is offline
    This user has no status.
     
    Established TTD Member 197 45
    #1

    Why is my rubber not doming after boosting?

    Hello, I'm trying boosting for the first time on a H3 neo and I'm using the Falco tempo long booster. I applied it after putting a thin layer of glue on the rubber just as the instructions said and waited until it dried to apply the glue. However, after waiting for eight hours, I still don't see the doming effect that I expected. Should I wait longer? Did I do something wrong?
    Last edited by sampletext; 07-23-2019 at 02:23 AM.

  2. UpSideDownCarl is offline
    says I like to hit Heavy Topspin
     
    Super Moderator 16,675 15,246
    UpSideDownCarl's Avatar
    UpSideDownCarl is offline
    says I like to hit Heavy Topspin
     
    Super Moderator 15,246 16,675
    #2
    Quote Originally Posted by sampletext
    Hello, I'm trying boosting for the first time on a H3 neo and I'm using the Falco tempo long booster. I applied it after putting a thin layer of glue on the rubber just as the instructions said and waited until it dried to apply the glue. However, after waiting for eight hours, I still don't see the doming effect that I expected. Should I wait longer? Did I do something wrong?
    How many layers of Falco did you put on the sponge?
    Setup 1: Blade by Nate: Vortex Spin Machine, FH Evolution MX-K, BH Evolution FX-P
    Setup 2: OSP Virtuoso Plus, FH Rasanter R 48, BH Rasanter R 48
    Spin is Everything

  3. sampletext is offline
    This user has no status.
     
    Established TTD Member 45 197
    S
    sampletext is offline
    This user has no status.
     
    Established TTD Member 197 45
    #3
    Quote Originally Posted by UpSideDownCarl
    How many layers of Falco did you put on the sponge?
    I only put one layer.

  4. UpSideDownCarl is offline
    says I like to hit Heavy Topspin
     
    Super Moderator 16,675 15,246
    UpSideDownCarl's Avatar
    UpSideDownCarl is offline
    says I like to hit Heavy Topspin
     
    Super Moderator 15,246 16,675
    #4
    Quote Originally Posted by sampletext
    I only put one layer.
    Don't people usually put 2 or 3 layers of boost on if it is H3?
    Setup 1: Blade by Nate: Vortex Spin Machine, FH Evolution MX-K, BH Evolution FX-P
    Setup 2: OSP Virtuoso Plus, FH Rasanter R 48, BH Rasanter R 48
    Spin is Everything

  5. sampletext is offline
    This user has no status.
     
    Established TTD Member 45 197
    S
    sampletext is offline
    This user has no status.
     
    Established TTD Member 197 45
    #5
    Quote Originally Posted by UpSideDownCarl
    Don't people usually put 2 or 3 layers of boost on if it is H3?
    yeah but I think you have to let it dry first. In my case, after a while where it was supposed to dome, it still hasn't it just feels like wet glue. I was going to apply more but there is still no doming yet.
    Last edited by sampletext; 07-23-2019 at 03:26 AM.

  6. symbat is offline
    This user has no status.
     
    TTD Member 24 84
    S
    symbat is offline
    This user has no status.
     
    TTD Member 84 24
    #6
    Quote Originally Posted by sampletext
    yeah but I think you have to let it dry first. In my case, after a while where it was supposed to dome, it still hasn't it just feels like wet glue. I was going to apply more but there is still no doming yet.
    Wet glue? How much did you put on? Got a pic?
    I have only been playing for about a year, so please take that into consideration when considering any advice I try to give you. Thanks.

  7. sampletext is offline
    This user has no status.
     
    Established TTD Member 45 197
    S
    sampletext is offline
    This user has no status.
     
    Established TTD Member 197 45
    #7
    Quote Originally Posted by symbat
    Wet glue? How much did you put on? Got a pic?
    I don't have a picture but the glue was pretty much dried when I put the booster on.

  8. symbat is offline
    This user has no status.
     
    TTD Member 24 84
    S
    symbat is offline
    This user has no status.
     
    TTD Member 84 24
    #8
    Quote Originally Posted by sampletext
    yeah but I think you have to let it dry first. In my case, after a while where it was supposed to dome, it still hasn't it just feels like wet glue. I was going to apply more but there is still no doming yet.
    What do you meant it feels like wet glue?

    I brushed a thin layer on a Stiga Genesis rubber and it domed no problem. It does not feel like wet glue.
    I have only been playing for about a year, so please take that into consideration when considering any advice I try to give you. Thanks.

  9. thom is offline
    This user has no status.
     
    Established TTD Member 13 148
    T
    thom is offline
    This user has no status.
     
    Established TTD Member 148 13

    User Info Menu


    Oct 2018
    Canada
    148
    13
    252
    Read 0 Reviews
    #9
    I don't remember how long I had to wait with FTL for the second layer but if you are not sure if the first layer is dry why don't you wait longer . You will need at least two layers for it to curl the rubber if it hadn't been boosted before

    The Following User Likes thom's Post:

    sampletext


  10. sampletext is offline
    This user has no status.
     
    Established TTD Member 45 197
    S
    sampletext is offline
    This user has no status.
     
    Established TTD Member 197 45
    #10
    Quote Originally Posted by symbat
    What do you meant it feels like wet glue?

    I brushed a thin layer on a Stiga Genesis rubber and it domed no problem. It does not feel like wet glue.
    Oh haha sorry I meant that the booster felt like wet glue but as of now it just looks like I never put any booster on in the first place

  11. Creek is offline
    This user has no status.
     
    Established TTD Member 89 137
    C
    Creek is offline
    This user has no status.
     
    Established TTD Member 137 89

    User Info Menu


    Feb 2019
    Germany
    137
    89
    248
    Read 2 Reviews
    #11
    H3 neo has a layer of glue on it right out of the packaging. Perhaps 1 layer is not enough to get through this?

    The Following User Likes Creek's Post:

    sampletext


  12. Loopadoop is offline
    This user has no status.
     
    Master TTD Member 547 2,205
    L
    Loopadoop is offline
    This user has no status.
     
    Master TTD Member 2,205 547
    #12
    Possible, the sponge moisture level of this sheet out of the packaging was below normal.

    The Following User Likes Loopadoop's Post:

    sampletext


  13. yogi_bear is offline
    This user has no status.
     
    Master TTD Member 2,891 5,963
    yogi_bear's Avatar
    yogi_bear is offline
    This user has no status.
     
    Master TTD Member 5,963 2,891
    #13
    Doming is visible aftet 2 layers.

    The Following User Likes yogi_bear's Post:

    sampletext


  14. SFF_lib is offline
    This user has no status.
     
    Master TTD Member 1,017 1,675
    SFF_lib's Avatar
    SFF_lib is offline
    This user has no status.
     
    Master TTD Member 1,675 1,017
    #14
    Quote Originally Posted by sampletext
    Hello, I'm trying boosting for the first time on a H3 neo and I'm using the Falco tempo long booster. I applied it after putting a thin layer of glue on the rubber just as the instructions said and waited until it dried to apply the glue. However, after waiting for eight hours, I still don't see the doming effect that I expected. Should I wait longer? Did I do something wrong?
    1 - what version of H3 is it? Provincial and national versions dome better than the commercial version.

    2- Neo H3 needs to be left out of the vacuum pack for a day or two before applying booster. This allowed the pre-applied glue to dry up.

    3 - yeah you probably haven't waited enough

    All the best

    Sent from my PAR-LX9 using Tapatalk

    The Following User Likes SFF_lib's Post:

    sampletext


  15. UpSideDownCarl is offline
    says I like to hit Heavy Topspin
     
    Super Moderator 16,675 15,246
    UpSideDownCarl's Avatar
    UpSideDownCarl is offline
    says I like to hit Heavy Topspin
     
    Super Moderator 15,246 16,675
    #15
    Just apply a second layer and see what happens. If when you wrote the OP, it was 8 hours after applying the first layer of boost, then now it is about 18 hours later. I would add a second and then decide if you want to add a 3rd layer a few hours later.

    The Following User Likes UpSideDownCarl's Post:

    sampletext

    Setup 1: Blade by Nate: Vortex Spin Machine, FH Evolution MX-K, BH Evolution FX-P
    Setup 2: OSP Virtuoso Plus, FH Rasanter R 48, BH Rasanter R 48
    Spin is Everything

  16. Shifu is offline
    says CHO!
     
    Senior TTD Member 603 771
    Shifu's Avatar
    Shifu is offline
    says CHO!
     
    Senior TTD Member 771 603

    User Info Menu


    Jan 2017
    Europe
    771
    603
    2217
    Read 2 Reviews
    #16
    and be sure to remove the protection layer

    The Following User Likes Shifu's Post:

    sampletext


  17. sampletext is offline
    This user has no status.
     
    Established TTD Member 45 197
    S
    sampletext is offline
    This user has no status.
     
    Established TTD Member 197 45
    #17
    Quote Originally Posted by SFF_lib
    1 - what version of H3 is it? Provincial and national versions dome better than the commercial version.

    2- Neo H3 needs to be left out of the vacuum pack for a day or two before applying booster. This allowed the pre-applied glue to dry up.

    3 - yeah you probably haven't waited enough

    All the best

    Sent from my PAR-LX9 using Tapatalk
    Yeah i boosted strait out of the pack, I applied booster to one new commercial and one old used provincial. So should I try to take it off?

  18. sampletext is offline
    This user has no status.
     
    Established TTD Member 45 197
    S
    sampletext is offline
    This user has no status.
     
    Established TTD Member 197 45
    #18
    Quote Originally Posted by Fabian
    and be sure to remove the protection layer
    I thought that was a booster layer.

  19. Shifu is offline
    says CHO!
     
    Senior TTD Member 603 771
    Shifu's Avatar
    Shifu is offline
    says CHO!
     
    Senior TTD Member 771 603

    User Info Menu


    Jan 2017
    Europe
    771
    603
    2217
    Read 2 Reviews
    #19
    I don’t mean on the sponge. I mean the topsheet.

  20. sampletext is offline
    This user has no status.
     
    Established TTD Member 45 197
    S
    sampletext is offline
    This user has no status.
     
    Established TTD Member 197 45
    #20
    Quote Originally Posted by Fabian
    I don’t mean on the sponge. I mean the topsheet.
    Oh yeah I took off All the protective sheets

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Create a new Topic:
Title is required.