What did I do wrong at boosting?

This user has no status.
This user has no status.
Member
Jun 2019
86
48
156
I wanted to boost H3 Neo Commercial but it didn't turn out as I would expect.

First I put on a layer of solvent based glue on the rubber, and then a thin layer of booster. After about 12 hours the rubber still hasn't
curved at all and I decided to put on another layer of booster, this time a bit thicker. This time the rubber domed quite heavily and it was still very domed 4 days after that, and it didn't look like it would un-dome more. I had to put it on my racket, because i needed to play. This was a bit of a challenge, because solvent glue curves the rubber even more, but I managed to stick it on the racket (but the lower edges seem to come off now).
What did I do wrong to make the rubber curve that much? Why wasn't there a dome after putting on the first layer of booster? I used Huieson glue and Seamoon Solubility Bond booster.
 
This user has no status.
This user has no status.
Well-Known Member
Jul 2018
1,011
558
1,962
Solvent based glue usually have a weaker bond. If you boost, make sure you use a stronger glue. DHS 15 works great with heavily curled rubbers.
 
This user has no status.
This user has no status.
Member
Oct 2019
19
4
30
I've only boosted 4 different rubbers or so but have noticed each additional layer of booster needs more time to uncurl than the last layer for some reason.

1st layer barely curls, and I usually put the 2nd layer on 12 hours later or so. After the 2nd layer though, I'm waiting at least 1-3 days for it to uncurl a bit before putting on the next layer.

With 4 layers of boosting, the whole process took 2.5 weeks from start to gluing on the blade, and the rubber still slightly curls off at the blade's edges. I'll probably have to wait 3 weeks next time lol.

I saw people post videos of people doing the whole process in a week or so. I dry under a fan as well and I don't think I apply nearly as much booster as they show (my rubber doesn't curl to the point of being a cylinder).

For what it's worth, I use a Falco Tempo Long on H3N. I try to apply the same amount of booster on each layer and I use water-based glue (FineZip).
 
  • Like
Reactions: loerting
This user has no status.
This user has no status.
Member
Oct 2019
19
4
30
To answer your question more directly though, my guess is you applied too thick of a layer for your second layer.

I wanted to boost H3 Neo Commercial but it didn't turn out as I would expect.

First I put on a layer of solvent based glue on the rubber, and then a thin layer of booster. After about 12 hours the rubber still hasn't
curved at all and I decided to put on another layer of booster, this time a bit thicker. This time the rubber domed quite heavily and it was still very domed 4 days after that, and it didn't look like it would un-dome more. I had to put it on my racket, because i needed to play. This was a bit of a challenge, because solvent glue curves the rubber even more, but I managed to stick it on the racket (but the lower edges seem to come off now).
What did I do wrong to make the rubber curve that much? Why wasn't there a dome after putting on the first layer of booster? I used Huieson glue and Seamoon Solubility Bond booster.
 
  • Like
Reactions: loerting
I agree with "what smash into net" said. 2nd Layer probable too much. I've had this happen to me in the past and with time (approx. 1.5 weeks) the doming eventually went down.

I wanted to boost H3 Neo Commercial but it didn't turn out as I would expect.

First I put on a layer of solvent based glue on the rubber, and then a thin layer of booster. After about 12 hours the rubber still hasn't
curved at all and I decided to put on another layer of booster, this time a bit thicker. This time the rubber domed quite heavily and it was still very domed 4 days after that, and it didn't look like it would un-dome more. I had to put it on my racket, because i needed to play. This was a bit of a challenge, because solvent glue curves the rubber even more, but I managed to stick it on the racket (but the lower edges seem to come off now).
What did I do wrong to make the rubber curve that much? Why wasn't there a dome after putting on the first layer of booster? I used Huieson glue and Seamoon Solubility Bond booster.
 
says 2023 Certified Organ Donor
says 2023 Certified Organ Donor
Well-Known Member
Sep 2011
12,911
13,377
30,686
Read 27 reviews
OP... you must have been boosting and texting at the same time. Yeah, that was it. There are like a GAZILLION of these threads on every TT forum of every language imaginable, and if anyone of any reasonable normal capibility would hit the damn search button twice, they would find more than enough data to accomplish that task well enough.

But what the heck, it is fun to complain on TT forums and since your comments did not result in (or solicit) anyone's fist to anyone's kisser, it is all good.
 
Top