PDA

View Full Version : Xiom Omega Asia IV got spot ???



huycd34
11-06-2011, 03:40 PM
It has happent to me twice that my Xiom Omega Asia IV got some spots on the surface.
First time happent after few months, but second time was just after 2 or 3 weeks.
Some ppl said that I hit too hard so the pimple inside got broken.

Has this happened to anyone else?

774

azlan
11-06-2011, 03:47 PM
Hi Huysc34, I didn't see any spots, but I can clearly see that there is a bubble on the surface. My team mate uses exactly the same rubber, but in black. He doesn't have such problem. I just think that your supplier may got a bad batch from the producer. My advice, go to the supplier and change the rubber. If he refuses, then get a new one from another supplier.

Mr. RicharD
11-06-2011, 08:37 PM
It could be the pips breaking, but I highly doubt it. It's incredibly hard to break inverted pips as the energy is designed to spread out rather than at specific points. I'd have to agree with azlan on this. It's most likely you've got a bad batch. To be honest it actually looks like you could even have a spec of dirt or something there too seeing as how small it is, grains of whatever can cause small pop ups like that. But if it's not that then you just got unlucky and you should be able to return the product for a trade in or what not as it's a poor selection. If you could also explain the environment where you play. It could be environmental where if it's too hot or cold the rubber may have a more tendency to cause bubbles.

MildSeven
12-04-2011, 08:32 AM
What kind of glue did you use?

papgesig
09-30-2012, 01:20 PM
Rubber Cement lmnk.....

Mauno100
10-01-2012, 02:17 PM
Yep omega asia 4's always brake on my forehand so can't play with them anymore. You should switch to another rubber.